User Tools

Site Tools


howto:super-patcher

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
howto:super-patcher [2019/07/10 16:26]
brett8883 Added [Super-Patcher] link
howto:super-patcher [2019/08/22 23:09] (current)
brett8883
Line 14: Line 14:
 | Phantom 4 Standard | v2.00.0700 | | Phantom 4 Standard | v2.00.0700 |
 | Phantom 4 Advanced | v1.00.0128 | | Phantom 4 Advanced | v1.00.0128 |
 +| Phantom 4 Pro V2 | v01.00.2200 |
 +| Inspire 2 | V01.02.0200 |
  
 ---- ----
Line 127: Line 129:
 ===PREREQUISITES=== ===PREREQUISITES===
  
-  * Mavic Pro or Mavic Pro Platinum has to be STOCK v01.04.0300 ​fw for all modules+  * Mavic Pro or Mavic Pro Platinum has to be on STOCK v01.04.0300 ​firmware ​for all modules
  
 or\\  or\\ 
  
-  * Spark has to be STOCK V01.00.0900 ​fw for all modules ​+  * Spark has to be STOCK V01.00.0900 ​firmware ​for all modules ​
  
 or\\ or\\
  
-  * Phantom 4 Professional has to be on STOCK v1.05.0600 ​fw for all modules+  * Phantom 4 Professional has to be on STOCK V1.05.0600 ​firmware ​for all modules
  
 or\\ or\\
  
-  * Phantom 4 standard has to be on 2.00.0700 ​ ​fw ​for all modules+  * Phantom 4 standard has to be on STOCK V02.00.0700 ​firmware ​for all modules
  
 or\\ or\\
  
-  * Phantom 4 advanced has to be on 1.00.0128 ​fw for all modules\\+  * Phantom 4 advanced has to be on STOCK V01.00.0128 ​firmware for all modules\\ 
 + 
 +or\\  
 + 
 +  * Phantom 4 Pro V2 has to be on STOCK V01.00.2200 firmware for all modules\\ 
 + 
 +or\\ 
 + 
 +  * Inspire 2 has to be on STOCK V01.02.0200 firmware ​for all modules\\
  
   * This means if your firmware is mixed with the flight controller of another firmware, even though it says you are on the correct firmware, you will need to flash a stock version of the correct firmware for you aircraft listed above TWICE to ensure all modules get flashed.   * This means if your firmware is mixed with the flight controller of another firmware, even though it says you are on the correct firmware, you will need to flash a stock version of the correct firmware for you aircraft listed above TWICE to ensure all modules get flashed.
Line 150: Line 160:
       * Get DUMLdore from here:​https://​github.com/​jezzab/​DUMLdore/​releases/​tag/​v3.20       * Get DUMLdore from here:​https://​github.com/​jezzab/​DUMLdore/​releases/​tag/​v3.20
   * Super-Patcher only runs on Windows   * Super-Patcher only runs on Windows
 +      * NOTE: Super-Patcher works best with Windows 10!
  
 ---- ----
Line 183: Line 194:
 //Q. Do I need a specific version of the DJI Go 4 app to get the benefits of this mod?// //Q. Do I need a specific version of the DJI Go 4 app to get the benefits of this mod?//
  
-*A. No, Super-Patcher is not dependent on an app so you can use any one you’d like.*+*A. No, Super-Patcher is not dependent on an app so you can use any one you’d like.*\\ 
 +  * NOTE: P4PV2 requires a modified app without the NFZ database. This is the only model with this requirement and it is only needed for NFZ capability 
  
 //Q. Do I need to do anything with the controller? Like upgrade/​downgrade the controller?//​ //Q. Do I need to do anything with the controller? Like upgrade/​downgrade the controller?//​
  
-*A. No, Super-Patcher doesn’t do anything with the controller and it makes no difference which controller firmware you are using.*+*A. No, Super-Patcher doesn’t do anything with the controller and it makes no difference which controller firmware you are using.*\\ 
 + 
 +//Q. Do I really have to use Windows 10 for this to work? 
 + 
 +*A. The recommendation to use Windows 10 is because older versions of Windows do not identify the ADB driver for DJI drones. There are multiple ways to remedy this. You can update the driver manually or try to try up in safe mode and enable unrecognized drivers but Windows 10 does recognize the driver so it is easiest to just use Windows 10.*  
  
  
howto/super-patcher.1562775993.txt.gz · Last modified: 2019/07/10 16:26 by brett8883